Jump to content

Juki 1508NH : Problems with corner stitches - bobbin thread coming up

Recommended Posts

Good afternoon

re checking #3 question. In doing this without a dial indicator its splitting hairs. 

So another observation in checking bdc of needle and better i suppose is looking in the end door at the linkage connector at the needle bar. This seems to me another viewable way to gauge BDC. With this i have to retract my saying having the ability to press the reset button at bdc by the measurement of splitting a hair. But any way thats my settings for now. With this machine at bdc and a maximum stitch setting I have no movement in the feed dog. Though again taking a sip of coffee and rotating the pulley top toward me maybe 1/8” I can push totally down on the reset splitting that hair it bottoms the button and just enough this results in a slight movement of the feed dog fore and aft when applying the reverse lever. 

For some reason related to this adjustment I noted in the manual on 10.1B as this is an NH.   I noted in the side bar

@ needle bar bdc   This is  apita


And thats noteworthy


Share this post

Link to post
Share on other sites

Reviving an old thread!

Was this issue ever solved? I purchased a Juki 1541s new and am experiencing the same problem. It worked perfectly fine sewing through thick leather assemblies, and through layers of cordura/nylon until recently. When turning my work, the thread would pull upwards and look like a 45 degree stitch as opposed to a neat 90 degree stitch. Changing needles, thread, or tension, doesn’t alleviate anything. I attached an image below and highlighted the issue. This was just scrap leather that i was experimenting on tension trying to fix the issue so excuse all the tension issues.


Share this post

Link to post
Share on other sites

And to clarify- I’ve changed fabrics (down to two layers of cotton poplin for (PPE masks), needles, thread. Same issue. 

my maintenance guy is out of shop during the pandemic so That’s currently not an option. It just started recently (after a year of no issues), and don’t recall any specific event that may have disrupted timing. 

Has there been any reported fixes to this over the years?


Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...