Jump to content

TECHSEW Bobbin Winder

Recommended Posts

I Have a Techsew 3650 HD that is working pretty well, bit I am having a problem with the attached bobbin winder. It winds fine, but the thread will not go onto the bobbin in the back and forth pattern. I have to manually move the thread, so the bobbin never fills evenly. I have tried moving the arm up and down, but no help. Any other suggestions?


Share this post

Link to post
Share on other sites
3 hours ago, AA3JW said:

so the bobbin never fills evenly

Have you tried winding the bobbin without the half moon shaped guide and guide stand removed then adding more tension on thread tension discs? A photo of the winder may also be helpful.


Share this post

Link to post
Share on other sites

Hard to tell w/o seeing pictures or seeing a video. However the curved piece between tensioner and bobbin holder probably needs an adjustment. That thingy is meant to fill the spool evenly. And (maybe) you have to play with the thread tension.

Few years ago I made an electric bobbin winder for my 45K / 45D (same bobbin as for the TS 3650 afaik) and w/o that curved thingy the bobbin was not filled evenly.



My machine mounted winder (ADLER made) also has this curved thingy.


Edited by Constabulary

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...